Install Phoronix Test Suite 1.8 y GUI

Agregar el repositorio

deb http://www.phoronix-test-suite.com/releases/repo pts.debian/

Instalar phoronix-test-suite.

Instalar la interfaz gráfica

Applications -> Accesories -> Terminal

The Phoronix GUI requires PHP-GTK2 which is unmaintained and dated, I found out that a patch needs to be applied to get php-gtk to compile.

1) Download & Extract

wget http://gtk.php.net/do_download.php?download_file=php-gtk-2.0.1.tar.gz

tar zxvf php-gtk-2.0.1.tar.gz

2) Install required dependancies

sudo apt-get install build-essential php5-cli php5-dev libgtk2.0-dev libglade2-dev

3) Download & Apply Patch

cd php-gtk-2.0.1

wget http://www.opsat.net/temp/buildfix.diff

patch -p1 < buildfix.diff

4) Compile

sudo ./buildconf
sudo ./configure
sudo make
sudo make install

5) Edit php.ini and load php-gtk module

sudo gedit /etc/php5/cli/php.ini

Find “Dynamic Extensions” section and add extension=php_gtk2.so

6) Test

cd demos
php phpgtk2-demo.php

There you have it!!! You now have the newest Phoronix Test Suite with GUI!!!

Now let’s add a menu entry (only for the GNOME environment)…

alacarte

Go to “System Tools” then “New Item”
Type: Application
Name: Phoronix Test Suite
Command: phoronix-test-suite gui

Fuente: Ubuntu Forum

4 responses to this post.

  1. Posted by David on 22 22UTC f 2010 at 00:28

    Hola robysottini,

    todo perfecto hasta el ‘sudo make’ … en ese punto obtuve unas 40 lineas con “ext/gtk+/gen_atk.c:272: error: duplicate ‘static’” más una última linea “make: *** [ext/gtk+/gen_atk.lo] Error 1”. Si te sirve de algo … estoy con Lucid Lynx Beta1 64bits y PTS 2.4.1 . Por aquello de que me había hecho la ilusión … a pesar del ‘kaske’ continué … en el ‘sudo make install’ me pasó lo mismo … y lo que es hacerse ilusiones … continué … hasta el casi el final y obtuve un triste “Unable to load dynamic library ‘/usr/lib/php5/20090626/php_gtk2.so’ – /usr/lib/php5/20090626/php_gtk2.so: cannot open shared object file: No such file or directory in Unknown on line 0” … ¿ se te ocurre qué puede suceder ? … gracias en cualquier caso. Pd. Desde luego ya le vale a Michael Larabel … podría traer su herramienta la interfaz gráfica por defecto … en fín …

    Responder

  2. Posted by DaveK on 7 07UTC f 2010 at 15:42

    I have this problem too:

    Unable to load dynamic library ‘/usr/lib/php5/20090626/php_gtk2.so’ – /usr/lib/php5/20090626/php_gtk2.so: cannot open shared object file:

    I am using Ubuntu 10.10, but this was working in 9.10 and earlier. Please share a solution!

    Responder

  3. Posted by zykral on 13 13UTC f 2010 at 12:48

    Año 2010 ¿Porqué es tan complicado?… existe un DEB y a pesar de ello la instalación es imposible.

    Me encuentro en la misma situación que DaveK .

    ——————–

    Year 2010. Why is it so complicated? … although there is DEB package… the installation is impossible.

    I am in same situation than DaveK.

    Responder

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: